UBUNTU-CVE-2026-96888: High severity ubuntu/bind9 vulnerability
A BIND resolver that is configured with both a "redirect" zone and "qname-minimization strict" may abort with an assertion failure while processing the redirect. This issue affects BIND 9 versions 9.16.0 through 9.18.50, 9.20.0 through 9.20.29, 9.21.0 through 9.21.26, 9.16.8-S1 through 9.18.50-S1, and 9.20.9-S1 through 9.20.29-S1.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/bind9to a version that resolves this vulnerability.Fixed in 1:9.18.39-0ubuntu0.22.04.8 - Upgrade
Upgrade
ubuntu/bind9to a version that resolves this vulnerability.Fixed in 1:9.18.39-0ubuntu0.24.04.9 - Upgrade
Upgrade
ubuntu/bind9to a version that resolves this vulnerability.Fixed in 1:9.20.24-1ubuntu3.1 - Upgrade
Upgrade
ubuntu/bind9to a version that resolves this vulnerability.Fixed in 1:9.20.24-1ubuntu0.5