UBUNTU-CVE-2026-97313: High severity ubuntu/bind9 vulnerability
A recursive BIND server that receives a query with recursion desired (RD=1) followed by a non-recursive query (RD=0) may exit with an assertion failure, resulting in a denial of service. To be vulnerable, the BIND server must allow recursive queries and have at least two RPZ zones configured: one with the default setting of "recursive-only yes", and the other with "recursive-only no". This issue affects BIND 9 versions 9.16.0 through 9.18.50, 9.20.0 through 9.20.29, 9.21.0 through 9.21.26, 9.11.3-S1 through 9.18.50-S1, and 9.20.9-S1 through 9.20.29-S1.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/bind9to a version that resolves this vulnerability.Fixed in 1:9.18.39-0ubuntu0.22.04.8 - Upgrade
Upgrade
ubuntu/bind9to a version that resolves this vulnerability.Fixed in 1:9.18.39-0ubuntu0.24.04.9 - Upgrade
Upgrade
ubuntu/bind9to a version that resolves this vulnerability.Fixed in 1:9.20.24-1ubuntu3.1 - Upgrade
Upgrade
ubuntu/bind9to a version that resolves this vulnerability.Fixed in 1:9.20.24-1ubuntu0.5