USN-7089-3: Linux kernel vulnerabilities

Published Nov 7, 2024
·
Updated

Chenyuan Yang discovered that the USB Gadget subsystem in the Linux kernel did not properly check for the device to be enabled before writing. A local attacker could possibly use this to cause a denial of service. (CVE-2024-25741) Several security issues were discovered in the Linux kernel. An attacker could possibly use these to compromise the system. This update corrects flaws in the following subsystems:

Affected Software

25 affected componentsFixes available
Ubuntu Linux kernel
All of the following
ubuntu/linux-image-6.8.0-1015-oracle<6.8.0-1015.16
6.8.0-1015.16
Ubuntu Ubuntu=24.04
All of the following
ubuntu/linux-image-6.8.0-1015-oracle-64k<6.8.0-1015.16
6.8.0-1015.16
Ubuntu Ubuntu=24.04
All of the following
ubuntu/linux-image-6.8.0-1018-aws<6.8.0-1018.20
6.8.0-1018.20
Ubuntu Ubuntu=24.04
All of the following
ubuntu/linux-image-aws<6.8.0-1018.20
6.8.0-1018.20
Ubuntu Ubuntu=24.04
All of the following
ubuntu/linux-image-oracle<6.8.0-1015.16
6.8.0-1015.16
Ubuntu Ubuntu=24.04
All of the following
ubuntu/linux-image-oracle-64k<6.8.0-1015.16
6.8.0-1015.16
Ubuntu Ubuntu=24.04
All of the following
ubuntu/linux-image-6.8.0-1015-oracle<6.8.0-1015.15~22.04.1
6.8.0-1015.15~22.04.1
Ubuntu Ubuntu=22.04
All of the following
ubuntu/linux-image-6.8.0-1015-oracle-64k<6.8.0-1015.15~22.04.1
6.8.0-1015.15~22.04.1
Ubuntu Ubuntu=22.04
All of the following
ubuntu/linux-image-6.8.0-1018-aws<6.8.0-1018.19~22.04.1
6.8.0-1018.19~22.04.1
Ubuntu Ubuntu=22.04
All of the following
ubuntu/linux-image-aws<6.8.0-1018.19~22.04.1
6.8.0-1018.19~22.04.1
Ubuntu Ubuntu=22.04
All of the following
ubuntu/linux-image-oracle<6.8.0-1015.15~22.04.1
6.8.0-1015.15~22.04.1
Ubuntu Ubuntu=22.04
All of the following
ubuntu/linux-image-oracle-64k<6.8.0-1015.15~22.04.1
6.8.0-1015.15~22.04.1
Ubuntu Ubuntu=22.04

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/linux-image-6.8.0-1015-oracle to a version that resolves this vulnerability.

    Fixed in 6.8.0-1015.16
  2. Upgrade

    Upgrade ubuntu/linux-image-6.8.0-1015-oracle-64k to a version that resolves this vulnerability.

    Fixed in 6.8.0-1015.16
  3. Upgrade

    Upgrade ubuntu/linux-image-6.8.0-1018-aws to a version that resolves this vulnerability.

    Fixed in 6.8.0-1018.20
  4. Upgrade

    Upgrade ubuntu/linux-image-aws to a version that resolves this vulnerability.

    Fixed in 6.8.0-1018.20
  5. Upgrade

    Upgrade ubuntu/linux-image-oracle to a version that resolves this vulnerability.

    Fixed in 6.8.0-1015.16
  6. Upgrade

    Upgrade ubuntu/linux-image-oracle-64k to a version that resolves this vulnerability.

    Fixed in 6.8.0-1015.16
  7. Upgrade

    Upgrade ubuntu/linux-image-6.8.0-1015-oracle to a version that resolves this vulnerability.

    Fixed in 6.8.0-1015.15~22.04.1
  8. Upgrade

    Upgrade ubuntu/linux-image-6.8.0-1015-oracle-64k to a version that resolves this vulnerability.

    Fixed in 6.8.0-1015.15~22.04.1
  9. Upgrade

    Upgrade ubuntu/linux-image-6.8.0-1018-aws to a version that resolves this vulnerability.

    Fixed in 6.8.0-1018.19~22.04.1
  10. Upgrade

    Upgrade ubuntu/linux-image-aws to a version that resolves this vulnerability.

    Fixed in 6.8.0-1018.19~22.04.1
  11. Upgrade

    Upgrade ubuntu/linux-image-oracle to a version that resolves this vulnerability.

    Fixed in 6.8.0-1015.15~22.04.1
  12. Upgrade

    Upgrade ubuntu/linux-image-oracle-64k to a version that resolves this vulnerability.

    Fixed in 6.8.0-1015.15~22.04.1
  13. Upgrade

    Upgrade Linux kernel to a version that resolves this vulnerability.

    Patch USN-7089-3

Event History

Nov 7, 2024
Advisory Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
DescriptionAffected Software

Frequently Asked Questions

1

What is the severity of USN-7089-3?

The severity of USN-7089-3 is related to a denial of service vulnerability in the USB Gadget subsystem of the Linux kernel.

2

How do I fix USN-7089-3?

To fix USN-7089-3, upgrade to the patched version of the Linux kernel image, specifically to version 6.8.0-1015.16 or higher.

3

What systems are affected by USN-7089-3?

USN-7089-3 affects Ubuntu 24.04 systems that use specific versions of the Linux kernel images listed in the advisory.

4

Who discovered the vulnerability in USN-7089-3?

The vulnerability in USN-7089-3 was discovered by Chenyuan Yang.

5

Is a local attacker required for exploiting USN-7089-3?

Yes, a local attacker could exploit USN-7089-3 to cause a denial of service.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203