CVE-2014-8540: Medium severity gitlab vulnerability

Published Jan 5, 2018
·
Updated

The groups API in GitLab 6.x and 7.x before 7.4.3 allows remote authenticated guest users to modify ownership of arbitrary groups by leveraging improper permission checks.

Affected Software

2 affected components
GitLab GitLab>=6.0.0<=6.9.2
GitLab GitLab>=7.0.0<7.4.3

Event History

Jan 5, 2018
CVE Published
via MITRE·04:00 PM
Data Sourced
via MITRE·04:00 PM
Description

Frequently Asked Questions

1

What is the severity of CVE-2014-8540?

CVE-2014-8540 has a medium severity rating due to improper permission checks that allow unauthorized group ownership modifications.

2

How do I fix CVE-2014-8540?

To fix CVE-2014-8540, upgrade GitLab to version 7.4.3 or later.

3

Who is affected by CVE-2014-8540?

CVE-2014-8540 affects remote authenticated guest users on GitLab versions 6.x and 7.x prior to 7.4.3.

4

What kind of vulnerability is CVE-2014-8540?

CVE-2014-8540 is a security vulnerability that allows modification of arbitrary group ownership.

5

Is there a workaround for CVE-2014-8540?

There is no specific workaround for CVE-2014-8540; the recommended action is to update to a secure version.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203