Where
-Infinity
0
EOL
May 15, 2025
Support Ends
Mar 20, 2025

End of life: 5/15/2025, End of support: 3/20/2025, Latest version: 17.9.8

First published (updated )
EOL
Nov 21, 2024
Support Ends
Sep 19, 2024

End of life: 11/21/2024, End of support: 9/19/2024, Latest version: 17.3.7

First published (updated )
EOL
Nov 21, 2024
Support Ends
Sep 19, 2024

End of life: 11/21/2024, End of support: 9/19/2024, Latest version: 17.3.7

First published (updated )
EOL
Jan 16, 2025
Support Ends
Nov 21, 2024

End of life: 1/16/2025, End of support: 11/21/2024, Latest version: 17.5.5

First published (updated )
EOL
Jan 16, 2025
Support Ends
Nov 21, 2024

End of life: 1/16/2025, End of support: 11/21/2024, Latest version: 17.5.5

First published (updated )
Severity
9.1
AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:L/A:N

An issue has been discovered in GitLab EE/CE affecting all versions starting from 8.0 before 16.4. The product did not sufficiently warn about security implications of granting merge rights to protected branches.

Remedy

Upgrade to versions 16.4 or above.
First published (updated )
EOL
Oct 17, 2024
Support Ends
Aug 15, 2024

End of life: 10/17/2024, End of support: 8/15/2024, Latest version: 17.2.9

First published (updated )
EOL
Oct 17, 2024
Support Ends
Aug 15, 2024

End of life: 10/17/2024, End of support: 8/15/2024, Latest version: 17.2.9

First published (updated )
EOL
Sep 22, 2023
Support Ends
Jul 22, 2023

End of life: 9/22/2023, End of support: 7/22/2023, Latest version: 16.1.8

First published (updated )
EOL
Sep 22, 2023
Support Ends
Jul 22, 2023

End of life: 9/22/2023, End of support: 7/22/2023, Latest version: 16.1.8

First published (updated )
EOL
Aug 22, 2023
Support Ends
Jun 22, 2023

End of life: 8/22/2023, End of support: 6/22/2023, Latest version: 16.0.10

First published (updated )
EOL
Aug 22, 2023
Support Ends
Jun 22, 2023

End of life: 8/22/2023, End of support: 6/22/2023, Latest version: 16.0.10

First published (updated )
EOL
Jan 18, 2024
Support Ends
Nov 16, 2023

End of life: 1/18/2024, End of support: 11/16/2023, Latest version: 16.5.10

First published (updated )
EOL
Jan 18, 2024
Support Ends
Nov 16, 2023

End of life: 1/18/2024, End of support: 11/16/2023, Latest version: 16.5.10

First published (updated )
EOL
Dec 21, 2023
Support Ends
Oct 22, 2023

End of life: 12/21/2023, End of support: 10/22/2023, Latest version: 16.4.7

First published (updated )
EOL
Dec 21, 2023
Support Ends
Oct 22, 2023

End of life: 12/21/2023, End of support: 10/22/2023, Latest version: 16.4.7

First published (updated )
EOL
Feb 15, 2024
Support Ends
Dec 21, 2023

End of life: 2/15/2024, End of support: 12/21/2023, Latest version: 16.6.10

First published (updated )
EOL
Feb 15, 2024
Support Ends
Dec 21, 2023

End of life: 2/15/2024, End of support: 12/21/2023, Latest version: 16.6.10

First published (updated )
EOL
Dec 19, 2024
Support Ends
Oct 17, 2024

End of life: 12/19/2024, End of support: 10/17/2024, Latest version: 17.4.6

First published (updated )
EOL
Dec 19, 2024
Support Ends
Oct 17, 2024

End of life: 12/19/2024, End of support: 10/17/2024, Latest version: 17.4.6

First published (updated )
EOL
Aug 15, 2024
Support Ends
Jun 20, 2024

End of life: 8/15/2024, End of support: 6/20/2024, Latest version: 17.0.8

First published (updated )
EOL
Aug 15, 2024
Support Ends
Jun 20, 2024

End of life: 8/15/2024, End of support: 6/20/2024, Latest version: 17.0.8

First published (updated )
EOL
Sep 19, 2024
Support Ends
Jul 18, 2024

End of life: 9/19/2024, End of support: 7/18/2024, Latest version: 17.1.8

First published (updated )
EOL
Sep 19, 2024
Support Ends
Jul 18, 2024

End of life: 9/19/2024, End of support: 7/18/2024, Latest version: 17.1.8

First published (updated )
EOL
Jul 18, 2024
Support Ends
May 16, 2024

End of life: 7/18/2024, End of support: 5/16/2024, Latest version: 16.11.10

First published (updated )
EOL
Jul 18, 2024
Support Ends
May 16, 2024

End of life: 7/18/2024, End of support: 5/16/2024, Latest version: 16.11.10

First published (updated )

This vulnerability allows remote attackers to create a denial-of-service condition on affected installations of GitLab. Authentication is required to exploit this vulnerability. The ZDI has assigned a CVSS rating of 4.3. The following CVEs are assigned: CVE-2024-2818.

First published (updated )
Advisory
ZDI-24-358

This vulnerability allows remote attackers to create a denial-of-service condition on affected installations of GitLab. Authentication is required to exploit this vulnerability. The ZDI has assigned a CVSS rating of 4.3. The following CVEs are assigned: CVE-2024-2818.

First published (updated )

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203