CVE-2017-11523: Medium severity ImageMagick ImageMagick vulnerability
The ReadTXTImage function in coders/txt.c in ImageMagick through 6.9.9 ...
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.6+deb12u11Fixed in 8:6.9.11.60+dfsg-1.6+deb12u15Fixed in 8:7.1.1.43+dfsg1-1+deb13u12Fixed in 8:7.1.1.43+dfsg1-1+deb13u13Fixed in 8:7.1.2.34+dfsg1-1
Event History
Frequently Asked Questions
What is the severity of CVE-2017-11523?
CVE-2017-11523 has been classified as a denial of service vulnerability due to the potential for an infinite loop.
How do I fix CVE-2017-11523?
To fix CVE-2017-11523, update ImageMagick to versions 6.9.11.60 or 7.1.1.43 or newer as they include patches for this vulnerability.
Which versions of ImageMagick are affected by CVE-2017-11523?
CVE-2017-11523 affects ImageMagick versions up to 6.9.9-0 and 7.x through 7.0.6-1.
What kind of attack does CVE-2017-11523 facilitate?
CVE-2017-11523 allows remote attackers to perform denial of service attacks via specially crafted TXT files.
Is CVE-2017-11523 a high-risk vulnerability?
Yes, CVE-2017-11523 is considered high-risk as it can lead to service interruptions due to the infinite loop.