CVE-2017-13139: Critical severity ImageMagick ImageMagick vulnerability
In ImageMagick before 6.9.9-0 and 7.x before 7.0.6-1, the ReadOneMNGIm ...
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u5Fixed in 8:6.9.11.60+dfsg-1.6+deb12u2Fixed in 8:6.9.11.60+dfsg-1.6+deb12u1Fixed in 8:7.1.1.43+dfsg1-1Fixed in 8:7.1.1.47+dfsg1-1 - Upgrade
Upgrade
ImageMagickto a version that resolves this vulnerability.Fixed in 6.9.9-0 - Upgrade
Upgrade
ImageMagickto a version that resolves this vulnerability.Fixed in 7.0.6-1
Event History
Frequently Asked Questions
What is the severity of CVE-2017-13139?
CVE-2017-13139 has a high severity rating due to its potential for out-of-bounds read vulnerabilities.
How do I fix CVE-2017-13139?
To fix CVE-2017-13139, update ImageMagick to version 7.0.6-1 or later.
What versions of ImageMagick are affected by CVE-2017-13139?
CVE-2017-13139 affects ImageMagick versions before 6.9.9-0 and 7.x before 7.0.6-1.
Is CVE-2017-13139 exploitable in all ImageMagick installations?
CVE-2017-13139 may be exploitable depending on how ImageMagick is used and what types of image files are processed.
What systems should be updated to mitigate CVE-2017-13139?
Systems running vulnerable versions of ImageMagick on Debian or Ubuntu should be updated to mitigate CVE-2017-13139.