CVE-2017-13141: Medium severity ImageMagick ImageMagick vulnerability
In ImageMagick before 6.9.9-4 and 7.x before 7.0.6-4, a crafted file could trigger a memory leak in ReadOnePNGImage in coders/png.c.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.6+deb12u11Fixed in 8:6.9.11.60+dfsg-1.6+deb12u15Fixed in 8:7.1.1.43+dfsg1-1+deb13u12Fixed in 8:7.1.1.43+dfsg1-1+deb13u13Fixed in 8:7.1.2.34+dfsg1-1
Event History
Frequently Asked Questions
What is the severity of CVE-2017-13141?
CVE-2017-13141 has a severity rating that indicates it can potentially lead to significant resource consumption through a memory leak.
How do I fix CVE-2017-13141?
To fix CVE-2017-13141, update ImageMagick to version 6.9.10.23 or later or the appropriate patched version provided by your distribution.
What versions of ImageMagick are affected by CVE-2017-13141?
CVE-2017-13141 affects ImageMagick versions before 6.9.9-4 and 7.x before 7.0.6-4.
Is CVE-2017-13141 exploitability high?
The exploitability of CVE-2017-13141 is considered moderate, as it requires the processing of a crafted PNG file.
What types of attacks can exploit CVE-2017-13141?
CVE-2017-13141 can be exploited through a denial-of-service attack due to the memory leak when processing malicious image files.