CVE-2017-13143: Infoleak
In ImageMagick before 6.9.7-6 and 7.x before 7.0.4-6, the ReadMATImage ...
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.6+deb12u11Fixed in 8:6.9.11.60+dfsg-1.6+deb12u15Fixed in 8:7.1.1.43+dfsg1-1+deb13u12Fixed in 8:7.1.1.43+dfsg1-1+deb13u13Fixed in 8:7.1.2.34+dfsg1-1 - Upgrade
Upgrade
ImageMagickto a version that resolves this vulnerability.Fixed in 6.9.7-6 - Upgrade
Upgrade
ImageMagickto a version that resolves this vulnerability.Fixed in 7.0.4-6
Event History
Frequently Asked Questions
What is CVE-2017-13143?
CVE-2017-13143 is a vulnerability in ImageMagick before 6.9.7-6 and 7.x before 7.0.4-6 that allows attackers to obtain sensitive information from process memory.
What is the severity of CVE-2017-13143?
The severity of CVE-2017-13143 is high, with a severity value of 7.5.
How does CVE-2017-13143 affect ImageMagick?
CVE-2017-13143 affects ImageMagick versions before 6.9.7-6 and 7.x before 7.0.4-6.
How can I fix CVE-2017-13143?
To fix CVE-2017-13143, update ImageMagick to version 6.9.7-6 or 7.x to version 7.0.4-6 or later.
Are there any additional references for CVE-2017-13143?
Yes, you can find more information about CVE-2017-13143 in the Debian bug report and the GitHub references provided.