CVE-2017-13777: Medium severity GraphicsMagick Graphicsmagick vulnerability
GraphicsMagick 1.3.26 has a denial of service issue in ReadXBMImage() in a coders/xbm.c "Read hex image data" version==10 case that results in the reader not returning; it would cause large amounts of CPU and memory consumption although the crafted file itself does not request it.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/graphicsmagickto a version that resolves this vulnerability.Fixed in 1.3.26-r3 - Upgrade
Upgrade
debian/graphicsmagickto a version that resolves this vulnerability.Fixed in 1.4+really1.3.40-4+deb12u1Fixed in 1.4+really1.3.45+hg17696-1Fixed in 1.4+really1.3.49-1
Event History
Frequently Asked Questions
What is the vulnerability ID for this issue?
The vulnerability ID for this issue is CVE-2017-13777.
What is the severity level of CVE-2017-13777?
The severity level of CVE-2017-13777 is high.
Which software versions are affected by CVE-2017-13777?
GraphicsMagick 1.3.26 is affected by CVE-2017-13777.
How can I fix CVE-2017-13777?
Upgrade to GraphicsMagick version 1.3.23-1ubuntu0.3 or higher.
Where can I find more information about CVE-2017-13777?
You can find more information about CVE-2017-13777 at the following references: http://openwall.com/lists/oss-security/2017/08/31/1, http://hg.code.sf.net/p/graphicsmagick/code/rev/233a720bfd5e, http://www.securityfocus.com/bid/100575