CVE-2017-16669: Buffer Overflow
coders/wpg.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted file, related to the AcquireCacheNexus function in magick/pixelcache.c.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/graphicsmagickto a version that resolves this vulnerability.Fixed in 1.3.27-r0 - Upgrade
Upgrade
debian/graphicsmagickto a version that resolves this vulnerability.Fixed in 1.4+really1.3.40-4+deb12u1Fixed in 1.4+really1.3.45+hg17696-1Fixed in 1.4+really1.3.49-1
Event History
Frequently Asked Questions
What is the vulnerability ID for this issue?
The vulnerability ID for this issue is CVE-2017-16669.
What is the severity of CVE-2017-16669?
The severity of CVE-2017-16669 is high, with a severity value of 8.8.
How does CVE-2017-16669 impact GraphicsMagick?
CVE-2017-16669 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact on GraphicsMagick.
How can I fix CVE-2017-16669?
To fix CVE-2017-16669, it is recommended to update GraphicsMagick to version 1.3.23-1ubuntu0.5 or higher.
Are there any references related to CVE-2017-16669?
Yes, you can find more information about CVE-2017-16669 at the following references: [Reference 1](http://hg.code.sf.net/p/graphicsmagick/code/rev/135bdcb88b8d), [Reference 2](http://hg.code.sf.net/p/graphicsmagick/code/rev/1b9e64a8901e), [Reference 3](http://hg.code.sf.net/p/graphicsmagick/code/rev/2a21cda3145b).