CVE-2017-17499: Use After Free
ImageMagick before 6.9.9-24 and 7.x before 7.0.7-12 has a use-after-fr ...
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.6+deb12u11Fixed in 8:6.9.11.60+dfsg-1.6+deb12u15Fixed in 8:7.1.1.43+dfsg1-1+deb13u12Fixed in 8:7.1.1.43+dfsg1-1+deb13u13Fixed in 8:7.1.2.34+dfsg1-1 - Upgrade
Upgrade
ImageMagickto a version that resolves this vulnerability.Fixed in 6.9.9-24 - Upgrade
Upgrade
ImageMagickto a version that resolves this vulnerability.Fixed in 7.0.7-12
Event History
Frequently Asked Questions
What is CVE-2017-17499?
CVE-2017-17499 is a vulnerability in ImageMagick that allows for a use-after-free in Magick::Image::read in Magick++/lib/Image.cpp.
How severe is CVE-2017-17499?
CVE-2017-17499 is considered critical with a severity score of 9.8 out of 10.
Which versions of ImageMagick are affected by CVE-2017-17499?
ImageMagick versions before 6.9.9-24 and 7.x before 7.0.7-12 are affected by CVE-2017-17499.
How can I fix CVE-2017-17499?
To fix CVE-2017-17499, you should update ImageMagick to version 6.9.9-24 or 7.0.7-12 or later.
Where can I find more information about CVE-2017-17499?
You can find more information about CVE-2017-17499 [here](https://github.com/ImageMagick/ImageMagick/commit/8c35502217c1879cb8257c617007282eee3fe1cc) and [here](https://github.com/ImageMagick/ImageMagick/commit/dd96d671e4d5ae22c6894c302e8996c13f24c45a).