CVE-2019-10714: Medium severity imagemagick vulnerability
Published Apr 2, 2019
·Updated
LocaleLowercase in MagickCore/locale.c in ImageMagick before 7.0.8-32 allows out-of-bounds access, leading to a SIGSEGV.
Affected Software
2 affected components
ImageMagick<6.9.10-32
ImageMagick>=7.0.0-0<7.0.8-32
Remediation
Patch Available
Event History
Apr 2, 2019
CVE Published
via MITRE·08:16 PM
Data Sourced
via MITRE·08:16 PM
Description
Frequently Asked Questions
1
What is the severity of CVE-2019-10714?
CVE-2019-10714 has a medium severity rating due to the potential for out-of-bounds access leading to a SIGSEGV.
2
Which versions of ImageMagick are affected by CVE-2019-10714?
CVE-2019-10714 affects ImageMagick versions before 7.0.8-32 and specific 6.x versions up to 6.9.10-32.
3
How do I fix CVE-2019-10714?
To resolve CVE-2019-10714, update ImageMagick to version 7.0.8-32 or later.
4
What type of vulnerability is CVE-2019-10714?
CVE-2019-10714 is an out-of-bounds access vulnerability found in the LocaleLowercase function.
5
Can CVE-2019-10714 be exploited remotely?
Yes, CVE-2019-10714 can potentially be exploited remotely if the affected software is exposed to untrusted input.