CVE-2019-17005: Buffer Overflow
Last updated 25 August 2025
Other sources
The plain text serializer used a fixed-size array for the number of
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/firefoxto a version that resolves this vulnerability.Fixed in 68.3 - Upgrade
Upgrade
redhat/thunderbirdto a version that resolves this vulnerability.Fixed in 68.3 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 68.3 - Upgrade
Upgrade
Firefoxto a version that resolves this vulnerability.Fixed in 71 - Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 68.3 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 149.0.2-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 115.14.0esr-1~deb11u1Fixed in 140.9.1esr-1~deb11u1Fixed in 128.14.0esr-1~deb12u1Fixed in 140.9.1esr-1~deb12u1Fixed in 140.8.0esr-1~deb13u1Fixed in 140.9.1esr-1~deb13u1Fixed in 140.9.1esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:115.12.0-1~deb11u1Fixed in 1:140.9.1esr-1~deb11u1Fixed in 1:140.6.0esr-1~deb12u1Fixed in 1:140.9.1esr-1~deb12u1Fixed in 1:140.8.0esr-1~deb13u1Fixed in 1:140.9.1esr-1~deb13u1Fixed in 1:140.9.0esr-1Fixed in 1:140.9.1esr-1 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 68.3.0-r0
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is CVE-2019-17005?
CVE-2019-17005 is a vulnerability that affects Thunderbird, Firefox ESR, and Firefox, leading to memory corruption and a potentially exploitable crash.
Which software versions are affected by CVE-2019-17005?
CVE-2019-17005 affects Thunderbird < 68.3, Firefox ESR < 68.3, and Firefox < 71.0.
What is the severity of CVE-2019-17005?
CVE-2019-17005 has a severity rating of 8.8 (high).
How can I fix CVE-2019-17005?
To fix CVE-2019-17005, you should update Thunderbird to version 68.3 or later, Firefox ESR to version 68.3 or later, and Firefox to version 71.0 or later.
Where can I find more information about CVE-2019-17005?
You can find more information about CVE-2019-17005 at the following references: [Bugzilla](https://bugzilla.mozilla.org/show_bug.cgi?id=1584170), [Mozilla Advisory](https://www.mozilla.org/en-US/security/advisories/mfsa2019-38/), [Mozilla Security Advisory](https://www.mozilla.org/security/advisories/mfsa2019-36/).