CVE-2020-10802: SQL injection relating to searching
In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not properly escaped when generating certain queries for search actions in libraries/classes/Controllers/Table/TableSearchController.php. An attacker can generate a crafted database or table name. The attack can be performed if a user attempts certain search operations on the malicious database or table.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 5.0.2 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.9.5 - Upgrade
Upgrade
alpine/phpmyadminto a version that resolves this vulnerability.Fixed in 4.9.5-r0 - Upgrade
Upgrade
alpine/phpmyadminto a version that resolves this vulnerability.Fixed in 5.0.2-r0
Event History
Frequently Asked Questions
What is CVE-2020-10802?
CVE-2020-10802 is a vulnerability related to SQL injection in the searching feature of phpMyAdmin.
What is the severity of CVE-2020-10802?
The severity of CVE-2020-10802 is high.
How does CVE-2020-10802 work?
CVE-2020-10802 allows an attacker to inject malicious SQL code through the search functionality of phpMyAdmin, leading to unauthorized access or manipulation of the database.
Is there any fix available for CVE-2020-10802?
Yes, phpMyAdmin has released a patch to fix CVE-2020-10802. It is recommended to upgrade to phpMyAdmin version 4.9.6 or 5.0.3 or later.
Where can I find more information about CVE-2020-10802?
You can find more information about CVE-2020-10802 on the official phpMyAdmin website: https://www.phpmyadmin.net/security/PMASA-2020-3/