CVE-2020-12417: High severity Mozilla Firefox vulnerability
Due to confusion about ValueTags on JavaScript Objects, an object may pass through the type barrier, resulting in memory corruption and a potentially exploitable crash. Note: this issue only affects Firefox on ARM64 platforms. This vulnerability affects Firefox ESR < 68.10, Firefox < 78, and Thunderbird < 68.10.0.
Other sources
Due to confusion about ValueTags on JavaScript Objects, an object may pass through the type barrier, resulting in memory corruption and a potentially exploitable crash.Note: this issue only affects Firefox on ARM64 platforms.
— Mozilla
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 68.10 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 78 - Upgrade
Upgrade
Firefoxto a version that resolves this vulnerability.Fixed in 78 - Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 68.10 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 149.0.2-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 115.14.0esr-1~deb11u1Fixed in 140.9.1esr-1~deb11u1Fixed in 128.14.0esr-1~deb12u1Fixed in 140.9.1esr-1~deb12u1Fixed in 140.8.0esr-1~deb13u1Fixed in 140.9.1esr-1~deb13u1Fixed in 140.9.1esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:115.12.0-1~deb11u1Fixed in 1:140.9.1esr-1~deb11u1Fixed in 1:140.6.0esr-1~deb12u1Fixed in 1:140.9.1esr-1~deb12u1Fixed in 1:140.8.0esr-1~deb13u1Fixed in 1:140.9.1esr-1~deb13u1Fixed in 1:140.9.0esr-1Fixed in 1:140.9.1esr-1 - Upgrade
Upgrade
alpine/firefoxto a version that resolves this vulnerability.Fixed in 78.0-r0 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 68.10.0-r0 - Upgrade
Upgrade
alpine/librewolfto a version that resolves this vulnerability.Fixed in 78.0-r0 - Upgrade
Upgrade
alpine/mozjs68to a version that resolves this vulnerability.Fixed in 68.10.0-r0 - Upgrade
Upgrade
alpine/thunderbirdto a version that resolves this vulnerability.Fixed in 68.10.0-r0 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 68.10.0
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the vulnerability ID for this issue?
The vulnerability ID for this issue is CVE-2020-12417.
Which platforms are affected by this vulnerability?
This vulnerability only affects Firefox on ARM64 platforms.
Which software versions are affected by this vulnerability?
This vulnerability affects Firefox ESR < 68.10, Firefox < 78, and Thunderbird < 78.
How severe is CVE-2020-12417?
CVE-2020-12417 has a severity rating of 8.8 (critical).
Where can I find more information about CVE-2020-12417?
You can find more information about CVE-2020-12417 in the following references: [Link](https://bugzilla.mozilla.org/show_bug.cgi?id=1640737), [Link](https://www.mozilla.org/en-US/security/advisories/mfsa2020-24/), [Link](http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00023.html).