CVE-2020-13284: Medium severity GitLab GitLab vulnerability
A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. API Authorization Using Outdated CI Job Token
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.1.10 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.2.8 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.3.4
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13284?
CVE-2020-13284 is rated as a high-severity vulnerability due to improper API authorization.
How do I fix CVE-2020-13284?
To fix CVE-2020-13284, upgrade GitLab to versions 13.1.10, 13.2.8, or 13.3.4 or later.
Which versions of GitLab are affected by CVE-2020-13284?
CVE-2020-13284 affects GitLab versions before 13.1.10, 13.2.8, and 13.3.4.
What types of GitLab are impacted by CVE-2020-13284?
Both GitLab Community and Enterprise editions are impacted by CVE-2020-13284.
Is CVE-2020-13284 related to CI job tokens?
Yes, CVE-2020-13284 involves API authorization issues stemming from outdated CI job tokens.