CVE-2020-13286: SSRF
For GitLab before 13.0.12, 13.1.6, 13.2.3 user controlled git configuration settings can be modified to result in Server Side Request Forgery.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.0.12 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.1.6 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.2.3
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13286?
CVE-2020-13286 has a CVSS score indicating it is a high severity vulnerability due to its potential for Server Side Request Forgery.
How do I fix CVE-2020-13286?
Fix CVE-2020-13286 by upgrading GitLab to version 13.0.12, 13.1.6, or 13.2.3 or later.
What is the impact of CVE-2020-13286?
The impact of CVE-2020-13286 allows attackers to manipulate git configuration settings, leading to unauthorized requests to internal services.
Which versions of GitLab are affected by CVE-2020-13286?
CVE-2020-13286 affects GitLab versions prior to 13.0.12, 13.1.6, and 13.2.3 for both community and enterprise editions.
Who is affected by CVE-2020-13286?
Users running affected versions of GitLab, both community and enterprise, are at risk from CVE-2020-13286.