CVE-2020-13289: Medium severity GitLab GitLab vulnerability
A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. In certain cases an invalid username could be accepted when 2FA is activated.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.1.10 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.2.8 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.3.4
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13289?
The severity of CVE-2020-13289 is classified as Medium.
How do I fix CVE-2020-13289?
To fix CVE-2020-13289, upgrade GitLab to version 13.1.10, 13.2.8, or 13.3.4 or later.
What systems are affected by CVE-2020-13289?
CVE-2020-13289 affects GitLab versions prior to 13.1.10, 13.2.8, and 13.3.4.
What kind of authentication issue is associated with CVE-2020-13289?
CVE-2020-13289 involves the acceptance of invalid usernames when two-factor authentication (2FA) is enabled.
Is CVE-2020-13289 related to any specific GitLab features?
Yes, CVE-2020-13289 is specifically related to the two-factor authentication feature in GitLab.