CVE-2020-13304: High severity GitLab GitLab vulnerability
A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. Same 2 factor Authentication secret code was generated which resulted an attacker to maintain access under certain conditions.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.1.10 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.2.8 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.3.4
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13304?
CVE-2020-13304 has a medium severity rating due to its potential impact on two-factor authentication mechanisms.
How do I fix CVE-2020-13304?
To fix CVE-2020-13304, upgrade GitLab to versions 13.1.10, 13.2.8, or 13.3.4 or later.
What versions of GitLab are affected by CVE-2020-13304?
CVE-2020-13304 affects GitLab versions prior to 13.1.10, 13.2.8, and 13.3.4.
What is the impact of CVE-2020-13304?
The impact of CVE-2020-13304 allows attackers to potentially maintain access through the same two-factor authentication secret code.
Is there a workaround for CVE-2020-13304?
No official workaround is provided for CVE-2020-13304, upgrading to a fixed version is recommended.