CVE-2020-13306: High severity GitLab GitLab vulnerability
A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. GitLab Webhook feature could be abused to perform denial of service attacks due to the lack of rate limitation.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.1.10 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.2.8 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.3.4
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13306?
CVE-2020-13306 is classified as a denial of service vulnerability due to lack of rate limiting in GitLab.
How do I fix CVE-2020-13306?
To fix CVE-2020-13306, upgrade GitLab to version 13.1.10, 13.2.8, or 13.3.4 or later.
What versions of GitLab are affected by CVE-2020-13306?
CVE-2020-13306 affects GitLab versions prior to 13.1.10, 13.2.8, and 13.3.4.
What kind of attack can be performed due to CVE-2020-13306?
CVE-2020-13306 can be exploited to conduct denial of service attacks on GitLab instances.
Is it safe to use GitLab versions below 13.1.10 after CVE-2020-13306?
No, using GitLab versions below 13.1.10 after CVE-2020-13306 is not safe due to the identified vulnerability.