CVE-2020-13309: SSRF
A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. GitLab was vulnerable to a blind SSRF attack through the repository mirroring feature.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.1.10 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.2.8 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.3.4
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13309?
CVE-2020-13309 has been classified as a critical vulnerability due to its potential to allow unauthorized access to sensitive data.
How do I fix CVE-2020-13309?
To fix CVE-2020-13309, upgrade your GitLab instance to version 13.1.10, 13.2.8, or 13.3.4 or later.
What affected versions are vulnerable to CVE-2020-13309?
Versions of GitLab before 13.1.10, 13.2.8, and 13.3.4 are vulnerable to CVE-2020-13309.
What can an attacker do with CVE-2020-13309?
An attacker exploiting CVE-2020-13309 can perform a blind SSRF attack, potentially accessing internal services or sensitive data.
Is CVE-2020-13309 widespread among GitLab installations?
Yes, CVE-2020-13309 affects a significant number of GitLab installations that have not been updated to the fixed versions.