CVE-2020-13314: Input Validation
A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. GitLab Omniauth endpoint allowed a malicious user to submit content to be displayed back to the user within error messages.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.1.10 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.2.8 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.3.4
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13314?
CVE-2020-13314 is classified as a medium severity vulnerability.
How do I fix CVE-2020-13314?
To fix CVE-2020-13314, upgrade GitLab to version 13.1.10, 13.2.8, or 13.3.4 or later.
What is the impact of CVE-2020-13314?
CVE-2020-13314 allows a malicious user to submit content that can lead to displayed error messages, potentially disclosing sensitive information.
Which versions of GitLab are affected by CVE-2020-13314?
CVE-2020-13314 affects GitLab versions prior to 13.1.10, 13.2.8, and 13.3.4.
Is CVE-2020-13314 relevant to both community and enterprise GitLab versions?
Yes, CVE-2020-13314 affects both community and enterprise editions of GitLab.