CVE-2020-13315: Input Validation
A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. The profile activity page was not restricting the amount of results one could request, potentially resulting in a denial of service.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.1.10 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.2.8 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.3.4
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13315?
CVE-2020-13315 has a severity rating that suggests it could lead to a denial of service due to unregulated request results.
How do I fix CVE-2020-13315?
To fix CVE-2020-13315, upgrade GitLab to versions 13.1.10, 13.2.8, or 13.3.4 or later.
What versions of GitLab are affected by CVE-2020-13315?
GitLab versions prior to 13.1.10, 13.2.8, and 13.3.4 are affected by CVE-2020-13315.
What type of vulnerability is CVE-2020-13315?
CVE-2020-13315 is classified as a denial of service vulnerability.
What is the root cause of CVE-2020-13315?
The root cause of CVE-2020-13315 is the lack of restrictions on the amount of results that can be requested on the profile activity page.