CVE-2020-13317: Input Validation
A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8, and 13.3.4. An insufficient check in the GraphQL api allowed a maintainer to delete a repository.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.3.4
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13317?
CVE-2020-13317 is considered a high severity vulnerability due to its potential impact on repository deletion by maintainers.
How do I fix CVE-2020-13317?
To fix CVE-2020-13317, upgrade GitLab to versions 13.1.10, 13.2.8, or 13.3.4 or later.
What types of GitLab versions are affected by CVE-2020-13317?
CVE-2020-13317 affects GitLab Community and Enterprise editions prior to versions 13.1.10, 13.2.8, and 13.3.4.
What is the impact of CVE-2020-13317?
The impact of CVE-2020-13317 allows unauthorized deletion of repositories by maintainers due to insufficient checks in the GraphQL API.
Is CVE-2020-13317 related to GraphQL vulnerabilities?
Yes, CVE-2020-13317 involves a vulnerability in the GraphQL API that permits inappropriate repository deletion.