CVE-2020-13323: High severity GitLab GitLab vulnerability
A vulnerability was discovered in GitLab versions prior 13.1. Under certain conditions private merge requests could be read via Todos
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.1
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13323?
CVE-2020-13323 has a moderate severity level as it affects the confidentiality of private merge requests.
How do I fix CVE-2020-13323?
To fix CVE-2020-13323, upgrade GitLab to the latest version that is not affected, specifically versions above 13.1.2.
Which GitLab versions are affected by CVE-2020-13323?
CVE-2020-13323 affects GitLab versions prior to 13.1 and several versions including 12.10.13 and 13.0.8.
What type of attack does CVE-2020-13323 represent?
CVE-2020-13323 represents a confidentiality attack where private merge requests can be unlawfully accessed.
How can I determine if my GitLab instance is vulnerable to CVE-2020-13323?
Check the version of your GitLab instance; if it is between 8.5.0 and 12.10.13 or between 13.0.0 and 13.1.2, it is vulnerable to CVE-2020-13323.