CVE-2020-13340: XSS
An issue has been discovered in GitLab affecting all versions prior to 13.2.10, 13.3.7 and 13.4.2: Stored XSS in CI Job Log
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.2.10 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.3.7 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.4.2
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13340?
CVE-2020-13340 has a medium severity rating due to its potential to allow stored XSS attacks.
How do I fix CVE-2020-13340?
To fix CVE-2020-13340, upgrade GitLab to version 13.2.10, 13.3.7, or 13.4.2 or later.
Which versions of GitLab are affected by CVE-2020-13340?
CVE-2020-13340 affects all GitLab versions prior to 13.2.10, 13.3.7, and 13.4.2.
What type of vulnerability is CVE-2020-13340?
CVE-2020-13340 is a stored cross-site scripting (XSS) vulnerability that impacts the CI job log in GitLab.
Can I still use my GitLab instance if it is vulnerable to CVE-2020-13340?
While you can continue to use your vulnerable GitLab instance, it is highly recommended to apply the necessary patches to mitigate the risk of XSS attacks.