CVE-2020-13341: Medium severity GitLab GitLab vulnerability
An issue has been discovered in GitLab affecting all versions prior to 13.2.10, 13.3.7 and 13.4.2. Insufficient permission check allows attacker with developer role to perform various deletions.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.2.10 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.3.7 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.4.2
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13341?
CVE-2020-13341 is considered a medium severity vulnerability due to insufficient permission checks in GitLab.
How do I fix CVE-2020-13341?
To fix CVE-2020-13341, update your GitLab installation to version 13.2.10, 13.3.7, or 13.4.2 or later.
Who is affected by CVE-2020-13341?
CVE-2020-13341 affects all versions of GitLab prior to 13.2.10, 13.3.7, and 13.4.2.
What kind of attacks can be performed due to CVE-2020-13341?
An attacker with a developer role can exploit CVE-2020-13341 to perform unauthorized deletions.
What versions of GitLab are impacted by CVE-2020-13341?
CVE-2020-13341 impacts GitLab community and enterprise versions from 13.1.0 up to, but not including, 13.2.10, 13.3.0 up to 13.3.7, and 13.4.0 up to 13.4.2.