CVE-2021-3043: Prisma Cloud: Cross-Site Scripting (XSS) Vulnerability in Prisma Cloud Compute Web Console
A reflected cross-site scripting (XSS) vulnerability exists in the Prisma Cloud Compute web console that enables a remote attacker to execute arbitrary JavaScript code in the browser-based web console while an authenticated administrator is using that web interface. Prisma Cloud Compute SaaS versions were automatically upgraded to the fixed release. No additional action is required for these instances. This issue impacts: Prisma Cloud Compute 20.12 versions earlier than Prisma Cloud Compute 20.12.552; Prisma Cloud Compute 21.04 versions earlier than Prisma Cloud Compute 21.04.439.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Prisma Cloud Computeto a version that resolves this vulnerability.Fixed in 20.12.552 - Upgrade
Upgrade
Prisma Cloud Computeto a version that resolves this vulnerability.Fixed in 21.04.439
Event History
Frequently Asked Questions
What is the severity of CVE-2021-3043?
CVE-2021-3043 is categorized as a medium severity reflected cross-site scripting (XSS) vulnerability.
How do I fix CVE-2021-3043?
To fix CVE-2021-3043, upgrade the Prisma Cloud Compute software to versions above 20.12.552 or 21.04.439.
Which versions of Prisma Cloud are affected by CVE-2021-3043?
CVE-2021-3043 affects Prisma Cloud Compute versions 20.12.0 to 20.12.552 and 21.04.0 to 21.04.439.
What impact does CVE-2021-3043 have on security?
CVE-2021-3043 allows attackers to execute arbitrary JavaScript code in the web console, potentially compromising authenticated sessions.
Is there a workaround for CVE-2021-3043 before upgrading?
Currently, there are no public workarounds for CVE-2021-3043, and upgrading is strongly recommended.