CVE-2021-37980: Inappropriate implementation in Sandbox

Published Sep 30, 2021
·
Updated

Inappropriate implementation in Sandbox in Google Chrome prior to 94.0.4606.81 allowed a remote attacker to potentially bypass site isolation via Windows.

Credit

Yonghwi Jin@@jinmo123(Theori)

Affected Software

19 affected componentsFixes available
Google Chrome<94.0.4606.81
94.0.4606.81
Google Chrome<94.0.4606.81
Microsoft Windows
Fedoraproject Fedora=33
Debian Debian Linux=10.0
Debian Debian Linux=11.0
All of the following
Google Chrome<94.0.4606.81
Microsoft Windows
alpine/qt5-qtwebengine<5.15.3_git20211006-r1
5.15.3_git20211006-r1
alpine/qt5-qtwebengine<5.15.3_git20211006-r3
5.15.3_git20211006-r3
alpine/qt5-qtwebengine<5.15.3_git20211006-r3
5.15.3_git20211006-r3
alpine/qt5-qtwebengine<5.15.3_git20211006-r3
5.15.3_git20211006-r3
alpine/qt5-qtwebengine<5.15.3_git20211006-r3
5.15.3_git20211006-r3
alpine/qt5-qtwebengine<5.15.3_git20211006-r3
5.15.3_git20211006-r3
alpine/qt5-qtwebengine<5.15.3_git20211006-r3
5.15.3_git20211006-r3
alpine/qt5-qtwebengine<5.15.3_git20211006-r3
5.15.3_git20211006-r3
alpine/qt5-qtwebengine<5.15.3_git20211006-r3
5.15.3_git20211006-r3
alpine/qt5-qtwebengine<5.15.3_git20211006-r3
5.15.3_git20211006-r3
debian/chromium
150.0.7871.100-1~deb12u1156.0.8078.79-1~deb12u1150.0.7871.181-1~deb13u1156.0.8078.79-1~deb13u1156.0.8078.79-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Google Chrome (Trace Event) to a version that resolves this vulnerability.

    Fixed in 94.0.4606.81
  2. Upgrade

    Upgrade alpine/qt5-qtwebengine to a version that resolves this vulnerability.

    Fixed in 5.15.3_git20211006-r1
  3. Upgrade

    Upgrade alpine/qt5-qtwebengine to a version that resolves this vulnerability.

    Fixed in 5.15.3_git20211006-r3
  4. Upgrade

    Upgrade debian/chromium to a version that resolves this vulnerability.

    Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1

Event History

Sep 30, 2021
CVE Published
12:00 AM
Oct 12, 2021
Exploit Published
via GitHub·07:14 PM
Nov 2, 2021
CVE Published
via MITRE·08:25 PM
Data Sourced
via MITRE·08:25 PM
DescriptionWeakness
Data Sourced
via NVD·09:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2021-37980?

CVE-2021-37980 is classified as a high severity vulnerability due to its potential to allow a remote attacker to bypass site isolation.

2

How do I fix CVE-2021-37980?

To fix CVE-2021-37980, update Google Chrome to version 94.0.4606.81 or later.

3

Which versions of Google Chrome are affected by CVE-2021-37980?

CVE-2021-37980 affects Google Chrome versions prior to 94.0.4606.81.

4

Can CVE-2021-37980 be exploited remotely?

Yes, CVE-2021-37980 can potentially be exploited by a remote attacker via the Windows platform.

5

Does CVE-2021-37980 affect other software besides Google Chrome?

CVE-2021-37980 specifically affects Google Chrome; other software listed may not be directly related but could have compatibility or operational implications.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203