CVE-2021-39877: High severity GitLab GitLab vulnerability
Published Oct 4, 2021
·Updated
A vulnerability was discovered in GitLab starting with version 12.2 that allows an attacker to cause uncontrolled resource consumption with a specially crafted file.
Affected Software
6 affected components
GitLab GitLab>=12.2.0<14.1.7
GitLab GitLab>=12.2.0<14.1.7
GitLab GitLab>=14.2<14.2.5
GitLab GitLab>=14.2<14.2.5
GitLab GitLab>=14.3<14.3.1
GitLab GitLab>=14.3<14.3.1
Event History
Oct 4, 2021
CVE Published
via MITRE·04:41 PM
Data Sourced
via MITRE·04:41 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·05:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·05:15 PM
DescriptionSeverity
Frequently Asked Questions
1
What is the severity of CVE-2021-39877?
CVE-2021-39877 has been rated as a high severity vulnerability due to its potential for causing uncontrolled resource consumption.
2
How do I fix CVE-2021-39877?
To mitigate CVE-2021-39877, upgrade your GitLab installation to version 14.1.7 or later, or 14.2.5 or later.
3
Which versions of GitLab are affected by CVE-2021-39877?
CVE-2021-39877 affects GitLab versions starting from 12.2.0 up to 14.1.7 and those in the 14.2.x stream before 14.2.5.
4
What types of attacks does CVE-2021-39877 enable?
CVE-2021-39877 allows attackers to exploit controlled resource consumption, potentially leading to service disruption.
5
Does CVE-2021-39877 affect both Community and Enterprise editions of GitLab?
Yes, CVE-2021-39877 affects both the Community and Enterprise editions of GitLab.