CVE-2022-1105: Medium severity GitLab GitLab vulnerability
An improper access control vulnerability in GitLab CE/EE affecting all versions from 13.11 prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 allows an unauthorized user to access pipeline analytics even when public pipelines are disabled
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 14.7.7 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 14.8.5 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 14.9.2
Event History
Frequently Asked Questions
What is the vulnerability ID of this vulnerability?
The vulnerability ID is CVE-2022-1105.
What is the severity of CVE-2022-1105?
The severity of CVE-2022-1105 is medium with a score of 4.3.
Which versions of GitLab are affected by CVE-2022-1105?
All versions from 13.11 prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 are affected.
What is the impact of CVE-2022-1105?
The vulnerability allows an unauthorized user to access pipeline analytics even when public pipelines are disabled.
Is there a fix available for CVE-2022-1105?
Yes, GitLab has released fixes for this vulnerability in versions 14.7.7, 14.8.5, and 14.9.2.