CVE-2022-1120: Medium severity GitLab GitLab vulnerability
Missing filtering in an error message in GitLab CE/EE affecting all versions prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 exposed sensitive information when an include directive fails in the CI/CD configuration.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 14.7.7 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 14.8.5 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 14.9.2
Event History
Frequently Asked Questions
What is the severity of CVE-2022-1120?
CVE-2022-1120 is classified as a high severity vulnerability due to the exposure of sensitive information.
How do I fix CVE-2022-1120?
To fix CVE-2022-1120, upgrade GitLab to version 14.7.7, 14.8.5, or 14.9.2 or later.
What kind of information is exposed by CVE-2022-1120?
CVE-2022-1120 can expose sensitive configuration data when an include directive fails in CI/CD setups.
Which versions of GitLab are affected by CVE-2022-1120?
CVE-2022-1120 affects all versions of GitLab prior to 14.7.7, versions 14.8 before 14.8.5, and 14.9 before 14.9.2.
What component of GitLab does CVE-2022-1120 affect?
CVE-2022-1120 affects the GitLab CI/CD configuration due to missing error message filtering.