CVE-2022-1121: Medium severity GitLab GitLab vulnerability
A lack of appropriate timeouts in GitLab Pages included in GitLab CE/EE all versions prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 allows an attacker to cause unlimited resource consumption.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLab CE/EE GitLab Pagesto a version that resolves this vulnerability.Fixed in 14.7.7 - Upgrade
Upgrade
GitLab CE/EE GitLab Pagesto a version that resolves this vulnerability.Fixed in 14.8.5 - Upgrade
Upgrade
GitLab CE/EE GitLab Pagesto a version that resolves this vulnerability.Fixed in 14.9.2
Event History
Frequently Asked Questions
What is the severity of CVE-2022-1121?
CVE-2022-1121 is considered a critical vulnerability due to the potential for unlimited resource consumption.
How do I fix CVE-2022-1121?
To fix CVE-2022-1121, upgrade to GitLab versions 14.7.7, 14.8.5, or 14.9.2 or later.
What systems are affected by CVE-2022-1121?
CVE-2022-1121 affects GitLab CE/EE versions prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2.
What type of attack does CVE-2022-1121 facilitate?
CVE-2022-1121 enables an attacker to launch Denial of Service (DoS) attacks through resource exhaustion.
Is CVE-2022-1121 present in all GitLab versions?
No, CVE-2022-1121 is only present in GitLab versions prior to the specified fixed versions.