CVE-2022-1157: Low severity GitLab GitLab vulnerability
Missing sanitization of logged exception messages in all versions prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 of GitLab CE/EE causes potential sensitive values in invalid URLs to be logged
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 14.7.7 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 14.8.5 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 14.9.2
Event History
Frequently Asked Questions
What is the severity of CVE-2022-1157?
CVE-2022-1157 is classified as a high severity vulnerability due to the potential exposure of sensitive information.
How do I fix CVE-2022-1157?
To remediate CVE-2022-1157, upgrade to GitLab version 14.7.7, 14.8.5, or 14.9.2 or later.
What versions of GitLab are affected by CVE-2022-1157?
CVE-2022-1157 affects all versions of GitLab prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2.
What type of information does CVE-2022-1157 potentially expose?
CVE-2022-1157 can potentially expose sensitive values found in invalid URLs logged by the application.
Is CVE-2022-1157 related to logging vulnerabilities?
Yes, CVE-2022-1157 involves missing sanitization of logged exception messages, which can lead to sensitive data exposure.