CVE-2022-22594: Input Validation
A cross-origin issue existed with the IndexedDB. This was addressed with improved checking of security origins.
Reference: https://webkitgtk.org/security/WSA-2022-0001.html
Other sources
A cross-origin issue in the IndexDB API was addressed with improved input validation. This issue is fixed in iOS 15.3 and iPadOS 15.3, watchOS 8.4, tvOS 15.3, Safari 15.3, macOS Monterey 12.2. A website may be able to track sensitive user information.
— MITRE
WebKit Storage. A cross-origin issue in the IndexDB API was addressed with improved input validation.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
tvOSto a version that resolves this vulnerability.Fixed in 15.3 - Upgrade
Upgrade
Apple iOS, iPadOS, and watchOSto a version that resolves this vulnerability.Fixed in 8.4 - Upgrade
Upgrade
macOSto a version that resolves this vulnerability.Fixed in 12.2 - Upgrade
Upgrade
Safarito a version that resolves this vulnerability.Fixed in 15.3 - Upgrade
Upgrade
Apple iOS and iPadOSto a version that resolves this vulnerability.Fixed in 15.3 - Upgrade
Upgrade
Apple iOS, iPadOS, and macOSto a version that resolves this vulnerability.Fixed in 15.3 - Upgrade
Upgrade
debian/webkit2gtkto a version that resolves this vulnerability.Fixed in 2.50.6-1~deb12u2Fixed in 2.50.6-1~deb12u1Fixed in 2.52.6-1~deb13u1Fixed in 2.54.0-1~deb13u3Fixed in 2.52.6-1Fixed in 2.54.2-2 - Upgrade
Upgrade
debian/wpewebkitto a version that resolves this vulnerability.Fixed in 2.38.6-1Fixed in 2.48.3-1Fixed in 2.54.2-1 - Upgrade
Upgrade
alpine/webkit2gtkto a version that resolves this vulnerability.Fixed in 2.34.4-r0 - Upgrade
Upgrade
debian/webkit2gtkto a version that resolves this vulnerability.Fixed in 2.34.4-1 - Upgrade
Upgrade
debian/wpewebkitto a version that resolves this vulnerability.Fixed in 2.34.4-1 - Upgrade
Upgrade
iOSto a version that resolves this vulnerability.Fixed in 15.3 - Upgrade
Upgrade
iPadOSto a version that resolves this vulnerability.Fixed in 15.3 - Upgrade
Upgrade
watchOSto a version that resolves this vulnerability.Fixed in 8.4 - Upgrade
Upgrade
macOS Montereyto a version that resolves this vulnerability.Fixed in 12.2
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is CVE-2022-22594?
CVE-2022-22594 is a vulnerability in WebKit Storage that involves a cross-origin issue in the IndexDB API.
Which software versions are affected by CVE-2022-22594?
CVE-2022-22594 affects Safari 15.3, watchOS up to 8.4, iOS up to 15.3, iPadOS up to 15.3, tvOS up to 15.3, and macOS Monterey up to 12.2.
How can I fix CVE-2022-22594?
To fix CVE-2022-22594, make sure to update your affected software to the recommended versions provided by Apple.
Where can I find more information about CVE-2022-22594?
You can find more information about CVE-2022-22594 on Apple's support page. Here are some relevant references: [reference1], [reference2], [reference3].
What is the CWE classification of CVE-2022-22594?
The CWE classification of CVE-2022-22594 is CWE-20, which stands for Improper Input Validation.