CVE-2022-22824: Integer Overflow

Published Jan 8, 2022
·
Updated

defineAttribute in xmlparse.c in Expat (aka libexpat) before 2.4.3 has an integer overflow.

Other sources

expat (libexpat) is susceptible to a software flaw that causes process interruption. When processing a large number of prefixed XML attributes on a single tag can libexpat can terminate unexpectedly due to integer overflow. The highest threat from this vulnerability is to availability, confidentiality and integrity.

Expat could allow a remote attacker to execute arbitrary code on the system, caused by an integer overflow of defineAttribute in xmlparse.c. By persuading a victim to open a specially-crafted file, an attacker could exploit this vulnerability to execute arbitrary code on the system.

— IBM

Affected Software

31 affected componentsFixes available
redhat/expat<0:2.1.0-14.el7_9
0:2.1.0-14.el7_9
redhat/expat<0:2.2.5-4.el8_5.3
0:2.2.5-4.el8_5.3
redhat/xmlrpc-c<0:1.51.0-8.el8
0:1.51.0-8.el8
IBM Cognos Analytics<=12.0.0-12.0.3
IBM Cognos Analytics<=11.2.0-11.2.4 FP4
Libexpat Project Libexpat<2.4.3
Tenable Nessus<8.15.3
Tenable Nessus>=10.0.0<10.1.1
Debian Debian Linux=10.0
Debian Debian Linux=11.0
Siemens SINEMA Remote Connect Server<3.1
redhat/expat<2.4.3
2.4.3
debian/expat<2.4.3-1
2.4.3-1
debian/expat<2.4.3-1
2.4.3-1
debian/expat<2.4.3-1
2.4.3-1
debian/libxmltok*
debian/expat
2.5.0-1+deb12u22.5.0-1+deb12u52.8.3-1~deb13u12.9.0-1~deb13u12.9.0-12.10.0-1
debian/libxmltok<=1.2-4
alpine/expat<2.2.10-r0
2.2.10-r0
alpine/expat<2.2.10-r2
2.2.10-r2
alpine/expat<2.4.3-r0
2.4.3-r0
alpine/expat<2.4.3-r0
2.4.3-r0
alpine/expat<2.4.3-r0
2.4.3-r0
alpine/expat<2.4.3-r0
2.4.3-r0
alpine/expat<2.4.3-r0
2.4.3-r0
alpine/expat<2.4.3-r0
2.4.3-r0
alpine/expat<2.4.3-r0
2.4.3-r0
alpine/expat<2.4.3-r0
2.4.3-r0
alpine/expat<2.4.3-r0
2.4.3-r0
alpine/expat<2.4.3-r0
2.4.3-r0
alpine/expat<2.4.3-r0
2.4.3-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/expat to a version that resolves this vulnerability.

    Fixed in 0:2.1.0-14.el7_9
  2. Upgrade

    Upgrade redhat/expat to a version that resolves this vulnerability.

    Fixed in 0:2.2.5-4.el8_5.3
  3. Upgrade

    Upgrade redhat/xmlrpc-c to a version that resolves this vulnerability.

    Fixed in 0:1.51.0-8.el8
  4. Upgrade

    Upgrade redhat/expat to a version that resolves this vulnerability.

    Fixed in 2.4.3
  5. Upgrade

    Upgrade debian/expat to a version that resolves this vulnerability.

    Fixed in 2.5.0-1+deb12u2Fixed in 2.5.0-1+deb12u5Fixed in 2.8.3-1~deb13u1Fixed in 2.9.0-1~deb13u1Fixed in 2.9.0-1Fixed in 2.10.0-1
  6. Upgrade

    Upgrade alpine/expat to a version that resolves this vulnerability.

    Fixed in 2.2.10-r0
  7. Upgrade

    Upgrade alpine/expat to a version that resolves this vulnerability.

    Fixed in 2.2.10-r2
  8. Upgrade

    Upgrade alpine/expat to a version that resolves this vulnerability.

    Fixed in 2.4.3-r0
  9. Upgrade

    Upgrade debian/expat to a version that resolves this vulnerability.

    Fixed in 2.4.3-1
  10. Upgrade

    Upgrade expat (libexpat) to a version that resolves this vulnerability.

    Fixed in 2.4.3

Event History

Jan 8, 2022
CVE Published
via MITRE·02:56 AM
Data Sourced
via MITRE·02:56 AM
Description
Jan 10, 2022
Data Sourced
via NVD·02:12 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·02:12 PM
DescriptionSeverityAffected Software
Jan 24, 2022
Data Sourced
via Red Hat·04:54 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is CVE-2022-22824?

CVE-2022-22824 is a vulnerability in Expat (libexpat) before 2.4.3, where the defineAttribute function in xmlparse.c is susceptible to an integer overflow.

2

How does CVE-2022-22824 affect the availability and confidentiality of a system?

CVE-2022-22824 poses a high threat to availability and confidentiality due to the potential for process interruption and unexpected termination.

3

Which software versions are affected by CVE-2022-22824?

CVE-2022-22824 affects Expat (libexpat) versions before 2.4.3.

4

What is the severity level of CVE-2022-22824?

CVE-2022-22824 has a severity level of critical with a score of 9.8.

5

Are there any references regarding CVE-2022-22824?

Yes, you can find references regarding CVE-2022-22824 at the following links: [link1], [link2], [link3].

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203