CVE-2022-25313: Medium severity Libexpat Project Libexpat vulnerability

Published Feb 18, 2022
·
Updated

A flaw was found in expat. A stack exhaustion in doctype parsing could be triggered by a file with a large number of opening braces, resulting in a denial of service.

Other sources

In Expat (aka libexpat) before 2.4.5, an attacker can trigger stack exhaustion in buildmodel via a large nesting depth in the DTD element.

Affected Software

32 affected componentsFixes available
redhat/mingw-expat<0:2.4.8-1.el8
0:2.4.8-1.el8
redhat/expat<0:2.2.5-8.el8_6.2
0:2.2.5-8.el8_6.2
redhat/expat<0:2.2.10-12.el9_0.2
0:2.2.10-12.el9_0.2
Libexpat Project Libexpat<2.4.5
Debian Debian Linux=10.0
Debian Debian Linux=11.0
Fedoraproject Fedora=34
Fedoraproject Fedora=35
Oracle HTTP Server=12.2.1.3.0
Oracle HTTP Server=12.2.1.4.0
Oracle ZFS Storage Appliance Kit=8.8
Siemens SINEMA Remote Connect Server<3.1
redhat/expat<2.4.5
2.4.5
debian/expat<2.4.5-1
2.4.5-1
debian/expat<2.4.5-1
2.4.5-1
debian/expat<2.4.5-1
2.4.5-1
debian/libxmltok*
debian/expat
2.5.0-1+deb12u22.5.0-1+deb12u52.8.3-1~deb13u12.9.0-1~deb13u12.9.0-12.10.0-1
debian/libxmltok<=1.2-4
alpine/expat<2.2.10-r2
2.2.10-r2
alpine/expat<2.2.10-r4
2.2.10-r4
alpine/expat<2.4.5-r0
2.4.5-r0
alpine/expat<2.4.5-r0
2.4.5-r0
alpine/expat<2.4.5-r0
2.4.5-r0
alpine/expat<2.4.5-r0
2.4.5-r0
alpine/expat<2.4.5-r0
2.4.5-r0
alpine/expat<2.4.5-r0
2.4.5-r0
alpine/expat<2.4.5-r0
2.4.5-r0
alpine/expat<2.4.5-r0
2.4.5-r0
alpine/expat<2.4.5-r0
2.4.5-r0
alpine/expat<2.4.5-r0
2.4.5-r0
alpine/expat<2.4.5-r0
2.4.5-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/mingw-expat to a version that resolves this vulnerability.

    Fixed in 0:2.4.8-1.el8
  2. Upgrade

    Upgrade redhat/expat to a version that resolves this vulnerability.

    Fixed in 0:2.2.5-8.el8_6.2
  3. Upgrade

    Upgrade redhat/expat to a version that resolves this vulnerability.

    Fixed in 0:2.2.10-12.el9_0.2
  4. Upgrade

    Upgrade redhat/expat to a version that resolves this vulnerability.

    Fixed in 2.4.5
  5. Upgrade

    Upgrade debian/expat to a version that resolves this vulnerability.

    Fixed in 2.5.0-1+deb12u2Fixed in 2.5.0-1+deb12u5Fixed in 2.8.3-1~deb13u1Fixed in 2.9.0-1~deb13u1Fixed in 2.9.0-1Fixed in 2.10.0-1
  6. Upgrade

    Upgrade alpine/expat to a version that resolves this vulnerability.

    Fixed in 2.2.10-r2
  7. Upgrade

    Upgrade alpine/expat to a version that resolves this vulnerability.

    Fixed in 2.2.10-r4
  8. Upgrade

    Upgrade alpine/expat to a version that resolves this vulnerability.

    Fixed in 2.4.5-r0
  9. Upgrade

    Upgrade debian/expat to a version that resolves this vulnerability.

    Fixed in 2.4.5-1
  10. Upgrade

    Upgrade expat (libexpat) to a version that resolves this vulnerability.

    Fixed in 2.4.5
  11. Compensating control

    Restrict applications using the expat (libexpat) library from processing untrusted XML content, as no other mitigation is known.

Event History

Feb 18, 2022
CVE Published
via MITRE·04:23 AM
Data Sourced
via MITRE·04:23 AM
Description
Data Sourced
via NVD·05:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·05:15 AM
DescriptionSeverityAffected Software
Feb 21, 2022
Data Sourced
via Red Hat·04:38 AM
DescriptionSeverityAffected Software
May 11, 2022
Exploit Published
via GitHub·07:40 AM

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is CVE-2022-25313?

CVE-2022-25313 is a vulnerability in Expat (aka libexpat) before version 2.4.5 that can trigger stack exhaustion and result in denial of service.

2

How severe is CVE-2022-25313?

CVE-2022-25313 has a severity value of 6.5, which is considered medium.

3

Which software is affected by CVE-2022-25313?

Expat versions before 2.4.5 are affected by CVE-2022-25313.

4

How can I fix CVE-2022-25313?

To fix CVE-2022-25313, update Expat to version 2.4.5 or later.

5

Where can I find more information about CVE-2022-25313?

You can find more information about CVE-2022-25313 at the following references: [link1], [link2], [link3].

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203