CVE-2022-25314: Integer Overflow
(from https://nvd.nist.gov/vuln/detail/CVE-2022-25314) In Expat (aka libexpat) before 2.4.5, there is an integer overflow in copyString.
In copyString of xmlparse.c, there is a possible memory corruption due to an integer overflow. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.
Other sources
An integer overflow flaw was found in expat. This issue affects the encoding name parameter at the parser creation time, which is often hard-coded (rather than user input), takes a value in the gigabytes to trigger, and on a 64-bit machine. This flaw can cause a denial of service.
In Expat (aka libexpat) before 2.4.5, there is an integer overflow in copyString.
https://github.com/libexpat/libexpat/pull/560 http://www.openwall.com/lists/oss-security/2022/02/19/1
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/mingw-expatto a version that resolves this vulnerability.Fixed in 0:2.4.8-1.el8 - Upgrade
Upgrade
redhat/expatto a version that resolves this vulnerability.Fixed in 0:2.2.5-8.el8_6.2 - Upgrade
Upgrade
redhat/expatto a version that resolves this vulnerability.Fixed in 0:2.2.10-12.el9_0.2 - Upgrade
Upgrade
debian/expatto a version that resolves this vulnerability.Fixed in 2.2.6-2+deb10u4Fixed in 2.2.6-2+deb10u6Fixed in 2.2.10-2+deb11u5Fixed in 2.5.0-1Fixed in 2.5.0-2 - Upgrade
Upgrade
redhat/expatto a version that resolves this vulnerability.Fixed in 2.4.5 - Upgrade
Upgrade
android/platform/external/expatto a version that resolves this vulnerability.Fixed in 10:2022-09-01 - Upgrade
Upgrade
android/platform/external/expatto a version that resolves this vulnerability.Fixed in 11:2022-09-01 - Upgrade
Upgrade
android/platform/external/expatto a version that resolves this vulnerability.Fixed in 12:2022-09-01 - Upgrade
Upgrade
android/platform/external/expatto a version that resolves this vulnerability.Fixed in 12L:2022-09-01 - Upgrade
Upgrade
Expat (libexpat)to a version that resolves this vulnerability.Fixed in 2.4.5 - Compensating control
Restrict applications using the Expat library from processing untrusted XML content.
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is CVE-2022-25314?
CVE-2022-25314 is a vulnerability in Expat (aka libexpat) before 2.4.5 that involves an integer overflow in copyString.
What is the severity of CVE-2022-25314?
The severity of CVE-2022-25314 is high, with a severity value of 7.5.
How does CVE-2022-25314 affect expat?
CVE-2022-25314 affects the encoding name parameter at the parser creation time in expat, potentially causing a denial of service.
How can I fix CVE-2022-25314?
To fix CVE-2022-25314, update Expat to version 2.4.5 or newer.
Where can I find more information about CVE-2022-25314?
More information about CVE-2022-25314 can be found in the references: [1] [2] [3].