CVE-2022-25858: Regular Expression Denial of Service (ReDoS)

Published Jul 15, 2022
·
Updated

A vulnerability was found in the terser package. Affected versions of this package are vulnerable to Regular expression denial of service (ReDoS) attacks, affecting system availability.

Other sources

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure usage of regular expressions.

Affected Software

8 affected componentsFixes available
terser Terser Node.js<4.8.1
terser Terser Node.js>=5.0.0<5.14.2
redhat/terser<4.8.1
4.8.1
redhat/terser<5.14.2
5.14.2
debian/node-terser<4.8.1-1
4.8.1-1
debian/node-terser<4.8.1-1
4.8.1-1
debian/node-terser<4.8.1-1
4.8.1-1
debian/node-terser
5.16.5-25.38.0-15.51.2-2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/terser to a version that resolves this vulnerability.

    Fixed in 4.8.1
  2. Upgrade

    Upgrade redhat/terser to a version that resolves this vulnerability.

    Fixed in 5.14.2
  3. Upgrade

    Upgrade debian/node-terser to a version that resolves this vulnerability.

    Fixed in 5.16.5-2Fixed in 5.38.0-1Fixed in 5.51.2-2
  4. Upgrade

    Upgrade debian/node-terser to a version that resolves this vulnerability.

    Fixed in 4.8.1-1
  5. Upgrade

    Upgrade terser to a version that resolves this vulnerability.

    Fixed in 4.8.1
  6. Upgrade

    Upgrade terser to a version that resolves this vulnerability.

    Fixed in 5.14.2
  7. Upgrade

    Upgrade terser to a version that resolves this vulnerability.

    Fixed in 5.0.0

Event History

Jul 15, 2022
CVE Published
12:00 AM
Data Sourced
12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·08:00 PM
Data Sourced
via MITRE·08:00 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·08:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·08:15 PM
DescriptionSeverityAffected Software
Sep 13, 2022
Data Sourced
via Red Hat·05:04 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2022-25858?

CVE-2022-25858 is classified as a moderate severity vulnerability due to its potential for denial of service attacks.

2

How do I fix CVE-2022-25858?

To mitigate CVE-2022-25858, upgrade Terser to version 4.8.1 or 5.14.2 or later.

3

What applications are impacted by CVE-2022-25858?

CVE-2022-25858 affects Terser versions prior to 4.8.1 and versions between 5.0.0 and 5.14.2.

4

What type of vulnerability is CVE-2022-25858?

CVE-2022-25858 is identified as a Regular Expression Denial of Service (ReDoS) vulnerability.

5

Is CVE-2022-25858 applicable to all Node.js applications?

CVE-2022-25858 specifically impacts applications using vulnerable versions of the Terser package, not all Node.js applications.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203