CVE-2022-28185: High severity Nvidia Virtual GPU vulnerability

Published May 17, 2022
·
Updated

NVIDIA GPU Display Driver for Windows and Linux contains a vulnerability in the ECC layer, where an unprivileged regular user can cause an out-of-bounds write, which may lead to denial of service and data tampering.

Affected Software

16 affected componentsFixes available
Nvidia Virtual GPU>=11.0<11.8
Nvidia Virtual GPU>=13.0<13.3
Nvidia Virtual GPU=14.0
Linux Linux kernel
Microsoft Windows
debian/nvidia-graphics-drivers<470.129.06-1
470.129.06-1
debian/nvidia-graphics-drivers<470.129.06-1
470.129.06-1
debian/nvidia-graphics-drivers<470.129.06-1
470.129.06-1
debian/nvidia-graphics-drivers-tesla-470<470.129.06-1
470.129.06-1
debian/nvidia-graphics-drivers
535.261.03-1535.309.01-0+deb12u1550.163.01-2550.163.01-5.1550.163.01-6
debian/nvidia-graphics-drivers-legacy-340xx<=340.108-28
debian/nvidia-graphics-drivers-legacy-390xx
390.157-16
debian/nvidia-graphics-drivers-tesla-418<=418.226.00-22
debian/nvidia-graphics-drivers-tesla-450
450.248.02-14
debian/nvidia-graphics-drivers-tesla-460<=460.106.00-24
debian/nvidia-graphics-drivers-tesla-470
470.256.02-1~deb12u1470.256.02-10

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/nvidia-graphics-drivers to a version that resolves this vulnerability.

    Fixed in 535.261.03-1Fixed in 535.309.01-0+deb12u1Fixed in 550.163.01-2Fixed in 550.163.01-5.1Fixed in 550.163.01-6
  2. Upgrade

    Upgrade debian/nvidia-graphics-drivers-legacy-390xx to a version that resolves this vulnerability.

    Fixed in 390.157-16
  3. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-450 to a version that resolves this vulnerability.

    Fixed in 450.248.02-14
  4. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-470 to a version that resolves this vulnerability.

    Fixed in 470.256.02-1~deb12u1Fixed in 470.256.02-10
  5. Upgrade

    Upgrade debian/nvidia-graphics-drivers to a version that resolves this vulnerability.

    Fixed in 470.129.06-1
  6. Upgrade

    Upgrade debian/nvidia-graphics-drivers-tesla-470 to a version that resolves this vulnerability.

    Fixed in 470.129.06-1

Event History

May 17, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionSeverityWeakness
Data Sourced
via OSV·08:15 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2022-28185?

CVE-2022-28185 is considered a critical vulnerability that can lead to denial of service and data tampering.

2

How do I fix CVE-2022-28185?

To fix CVE-2022-28185, you should update the NVIDIA GPU Display Driver to a version above the affected versions listed.

3

Who is affected by CVE-2022-28185?

CVE-2022-28185 affects users of the NVIDIA vGPU Software versions between 11.0-11.8 and 13.0-13.3, as well as version 14.0.

4

What are the risks associated with CVE-2022-28185?

The risks include potential system crashes due to denial of service and unauthorized data manipulation.

5

Is CVE-2022-28185 applicable to Linux kernel or Windows OS?

No, CVE-2022-28185 specifically affects the NVIDIA GPU Display Driver and does not impact the Linux kernel or Windows OS directly.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203