CVE-2022-3819: Medium severity GitLab GitLab vulnerability
An improper authorization issue in GitLab CE/EE affecting all versions from 15.0 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2 allows a malicious users to set emojis on internal notes they don't have access to.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 15.3.5 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 15.4.4 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 15.5.2
Event History
Frequently Asked Questions
What is the severity of CVE-2022-3819?
CVE-2022-3819 is considered a moderate severity vulnerability due to the improper authorization issue it presents.
How do I fix CVE-2022-3819?
To fix CVE-2022-3819, you should upgrade GitLab CE/EE to versions 15.3.5, 15.4.4, or 15.5.2 and above.
What versions are affected by CVE-2022-3819?
CVE-2022-3819 affects GitLab CE/EE versions from 15.0 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2.
What type of vulnerability is CVE-2022-3819?
CVE-2022-3819 is classified as an improper authorization vulnerability.
Who can exploit CVE-2022-3819?
Malicious users with access to the GitLab instance can exploit CVE-2022-3819 to set emojis on internal notes they do not have permissions for.