CVE-2022-40957: Medium severity Mozilla Thunderbird vulnerability
Inconsistent data in instruction and data cache when creating wasm code could lead to a potentially exploitable crash.<br>This bug only affects Firefox on ARM64 platforms.. This vulnerability affects Firefox ESR < 102.3, Thunderbird < 102.3, and Firefox < 105.
Other sources
Inconsistent data in instruction and data cache when creating wasm code could lead to a potentially exploitable crash.This bug only affects Firefox on ARM64 platforms.
— Mozilla
Inconsistent data in instruction and data cache when creating wasm code could lead to a potentially exploitable crash.This bug only affects Thunderbird on ARM64 platforms.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 102.3 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 102.3 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 105 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 102.3.0-r0 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 102.3.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:102.3.0-1 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0.1-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is CVE-2022-40957?
CVE-2022-40957 is a vulnerability that affects Firefox ESR < 102.3, Thunderbird < 102.3, and Firefox < 105, which can lead to a potentially exploitable crash due to inconsistent data in instruction and data cache when creating wasm code.
Which platforms are affected by CVE-2022-40957?
Only Firefox on ARM64 platforms is affected by CVE-2022-40957.
What is the severity level of CVE-2022-40957?
CVE-2022-40957 has a severity level of medium with a CVSS score of 6.5.
How can I fix CVE-2022-40957?
To fix CVE-2022-40957, update your Firefox ESR to version 102.3 or later, Thunderbird to version 102.3 or later, or Firefox to version 105 or later.
Where can I find more information about CVE-2022-40957?
You can find more information about CVE-2022-40957 on the Mozilla Bugzilla page and the Mozilla Security Advisories page.