CVE-2022-47977: Buffer Overflow
A vulnerability has been identified in JT Open (All versions < V11.2.3.0), JT Utilities (All versions < V13.2.3.0). The affected application contains a memory corruption vulnerability while parsing specially crafted JT files. This could allow an attacker to execute code in the context of the current process.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
JT Opento a version that resolves this vulnerability.Fixed in V11.2.3.0 - Upgrade
Upgrade
JT Utilitiesto a version that resolves this vulnerability.Fixed in V13.2.3.0
Event History
Frequently Asked Questions
What is the severity of CVE-2022-47977?
The severity of CVE-2022-47977 is high with a CVSS score of 7.8.
Which versions of JT Open are affected by CVE-2022-47977?
JT Open versions prior to V11.2.3.0 are affected by CVE-2022-47977.
Which versions of JT Utilities are affected by CVE-2022-47977?
JT Utilities versions prior to V13.2.3.0 are affected by CVE-2022-47977.
What is the impact of CVE-2022-47977?
CVE-2022-47977 could allow an attacker to execute code in the context of the current user.
How can I fix CVE-2022-47977?
Update JT Open to version V11.2.3.0 or later, and JT Utilities to version V13.2.3.0 or later to fix CVE-2022-47977.