CVE-2023-0155: Medium severity gitlab vulnerability
Published May 3, 2023
·Updated
An issue has been discovered in GitLab CE/EE affecting all versions before 15.8.5, 15.9.4, 15.10.1. Open redirects was possible due to framing arbitrary content on any page allowing user controlled markdown
Affected Software
6 affected components
GitLab GitLab<15.8.5
GitLab GitLab<15.8.5
GitLab GitLab>=15.9<15.9.5
GitLab GitLab>=15.9<15.9.5
GitLab GitLab>=15.10<15.10.1
GitLab GitLab>=15.10<15.10.1
Event History
May 3, 2023
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionSeverityWeakness
Data Sourced
09:15 PM
Description
Frequently Asked Questions
1
What is the severity of CVE-2023-0155?
CVE-2023-0155 has a medium severity rating due to the potential for open redirects.
2
How do I fix CVE-2023-0155?
To fix CVE-2023-0155, upgrade GitLab to versions 15.8.5, 15.9.4, or 15.10.1 or later.
3
Which versions of GitLab are affected by CVE-2023-0155?
CVE-2023-0155 affects all versions of GitLab before 15.8.5, 15.9.4, and 15.10.1.
4
What impact does CVE-2023-0155 have on GitLab users?
CVE-2023-0155 can lead to open redirects, allowing attackers to potentially mislead users through crafted links.
5
What steps should be taken if using an affected version of GitLab due to CVE-2023-0155?
Users of affected GitLab versions should prioritize upgrading to the latest secure versions to mitigate the risk.