CVE-2023-2200: Improper Encoding or Escaping of Output in GitLab
An issue has been discovered in GitLab CE/EE affecting all versions starting from 7.14 before 15.11.10, all versions starting from 16.0 before 16.0.6, all versions starting from 16.1 before 16.1.1, which allows an attacker to inject HTML in an email address field.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 15.11.10 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 16.0.6 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 16.1.1
Event History
Frequently Asked Questions
What is the vulnerability ID for this GitLab issue?
The vulnerability ID for this GitLab issue is CVE-2023-2200.
What is the severity rating of CVE-2023-2200?
The severity rating of CVE-2023-2200 is medium.
What versions of GitLab are affected by CVE-2023-2200?
All versions of GitLab starting from 7.14 before 15.11.10, starting from 16.0 before 16.0.6, and starting from 16.1 before 16.1.1 are affected.
What is the impact of the vulnerability in CVE-2023-2200?
The vulnerability allows an attacker to inject HTML in an email address field.
Is there a fix available for CVE-2023-2200?
Yes, GitLab has released patches to fix the vulnerability. It is recommended to update to the latest version of GitLab.