CVE-2023-25728: High severity Mozilla Thunderbird vulnerability
Last updated 24 July 2024
Other sources
The Content-Security-Policy-Report-Only header could allow an attacker to leak a child iframe's unredacted URI when interaction with that iframe triggers a redirect.
External Reference: https://www.mozilla.org/en-US/security/advisories/mfsa2023-06/#CVE-2023-25728
— Red Hat
The <code>Content-Security-Policy-Report-Only</code> header could allow an attacker to leak a child iframe's unredacted URI when interaction with that iframe triggers a redirect. This vulnerability affects Firefox < 110, Thunderbird < 102.8, and Firefox ESR < 102.8.
The Content-Security-Policy-Report-Only header could allow an attacker to leak a child iframe's unredacted URI when interaction with that iframe triggers a redirect.
The Mozilla Foundation Security Advisory describes this flaw as: The Content-Security-Policy-Report-Only header could allow an attacker to leak a child iframe's unredacted URI when interaction with that iframe triggers a redirect.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/firefoxto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el7_9 - Upgrade
Upgrade
redhat/thunderbirdto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el7_9 - Upgrade
Upgrade
redhat/firefoxto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el8_7 - Upgrade
Upgrade
redhat/thunderbirdto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el8_7 - Upgrade
Upgrade
redhat/firefoxto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el8_1 - Upgrade
Upgrade
redhat/thunderbirdto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el8_1 - Upgrade
Upgrade
redhat/firefoxto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el8_2 - Upgrade
Upgrade
redhat/thunderbirdto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el8_2 - Upgrade
Upgrade
redhat/firefoxto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el8_4 - Upgrade
Upgrade
redhat/thunderbirdto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el8_4 - Upgrade
Upgrade
redhat/firefoxto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el8_6 - Upgrade
Upgrade
redhat/thunderbirdto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el8_6 - Upgrade
Upgrade
redhat/firefoxto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el9_1 - Upgrade
Upgrade
redhat/thunderbirdto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el9_1 - Upgrade
Upgrade
redhat/firefoxto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el9_0 - Upgrade
Upgrade
redhat/thunderbirdto a version that resolves this vulnerability.Fixed in 0:102.8.0-2.el9_0 - Upgrade
Upgrade
redhat/firefoxto a version that resolves this vulnerability.Fixed in 102.8 - Upgrade
Upgrade
redhat/thunderbirdto a version that resolves this vulnerability.Fixed in 102.8 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 102.8 - Upgrade
Upgrade
Firefoxto a version that resolves this vulnerability.Fixed in 110 - Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 102.8 - Upgrade
Upgrade
alpine/firefox-esrto a version that resolves this vulnerability.Fixed in 102.8.0-r0 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0.1-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
- CVE-2023-0616
- CVE-2023-25728
- CVE-2023-25730
- CVE-2023-0767
- CVE-2023-25735
- CVE-2023-25737
- CVE-2023-25738
- CVE-2023-25739
- CVE-2023-25729
- CVE-2023-25732
- CVE-2023-25734
- CVE-2023-25742
- CVE-2023-25746
- CVE-2023-25743
- CVE-2023-25740
- CVE-2023-25731
- CVE-2023-25733
- CVE-2023-25736
- CVE-2023-25741
- CVE-2023-25744
- CVE-2023-25745
- DLA-3319-1
- DLA-3324-1
Frequently Asked Questions
What is the vulnerability ID for this issue?
The vulnerability ID for this issue is CVE-2023-25728.
Which software products are affected by this vulnerability?
This vulnerability affects Mozilla Firefox < 110, Mozilla Thunderbird < 102.8, and Firefox ESR < 102.8.
What is the severity of CVE-2023-25728?
The severity of CVE-2023-25728 is high (severity value: 7).
How can I fix the vulnerability CVE-2023-25728?
To fix the vulnerability CVE-2023-25728, upgrade to Mozilla Firefox version 110 or later, Mozilla Thunderbird version 102.8 or later, or Firefox ESR version 102.8 or later.
Where can I find more information about CVE-2023-25728?
You can find more information about CVE-2023-25728 in the following references: [Mozilla Bugzilla](https://bugzilla.mozilla.org/show_bug.cgi?id=1790345), [Mozilla Security Advisory](https://www.mozilla.org/security/advisories/mfsa2023-05/), [Mozilla Security Advisory](https://www.mozilla.org/security/advisories/mfsa2023-07/).