Advisory Published

CVE-2023-25859: Input Validation

First published: Wed Mar 22 2023(Updated: )

Illustrator version 26.5.2 (and earlier) and 27.2.0 (and earlier) are affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Credit: psirt@adobe.com

Affected SoftwareAffected VersionHow to fix
Adobe Illustrator<=26.5.2
Adobe Illustrator>=27.0.0<27.3.1
Apple macOS
Microsoft Windows

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Frequently Asked Questions

  • What is the severity of CVE-2023-25859?

    The severity of CVE-2023-25859 is high with a score of 7.8.

  • What is the affected software?

    The affected software is Adobe Illustrator versions 26.5.2 and earlier, and versions 27.2.0 and earlier.

  • How can the CVE-2023-25859 vulnerability be exploited?

    The CVE-2023-25859 vulnerability can be exploited by opening a malicious file, which may result in arbitrary code execution.

  • Is Apple macOS vulnerable to CVE-2023-25859?

    No, Apple macOS is not vulnerable to CVE-2023-25859.

  • Is Microsoft Windows vulnerable to CVE-2023-25859?

    No, Microsoft Windows is not vulnerable to CVE-2023-25859.


SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203