CVE-2024-10464: High severity Mozilla Thunderbird vulnerability

Published Oct 29, 2024
·
Updated

Last updated 6 November 2024

Other sources

Repeated writes to history interface attributes could have been used to cause a Denial of Service condition in the browser. This was addressed by introducing rate-limiting to this API.

— Mozilla

Affected Software

17 affected componentsFixes available
Mozilla Thunderbird<128.4
128.4
Mozilla Thunderbird<132
132
Mozilla Firefox<128.4.0
Mozilla Firefox<132.0
Mozilla Thunderbird<128.4.0
Mozilla Thunderbird>=129.0<132.0
Mozilla Firefox<132
132
Mozilla Firefox ESR<128.4
128.4
debian/firefox-esr<128.4.0esr-1~deb12u1
128.4.0esr-1~deb12u1
debian/firefox-esr<128.4.0esr-1
128.4.0esr-1
debian/firefox-esr<128.4.0esr-1
128.4.0esr-1
debian/thunderbird<1:128.4.0esr-1~deb12u1
1:128.4.0esr-1~deb12u1
debian/thunderbird<1:128.4.0esr-1
1:128.4.0esr-1
debian/thunderbird<1:128.4.0esr-1
1:128.4.0esr-1
debian/firefox
159.0-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u21:140.12.0esr-1~deb13u11:153.6.0esr-1~deb13u11:153.5.0esr-11:153.6.0esr-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 132.0.1-1
  2. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 128.4.0esr-1~deb11u1Fixed in 128.4.0esr-1~deb12u1Fixed in 128.4.0esr-1
  3. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:128.4.0esr-1~deb11u1Fixed in 1:128.4.0esr-1~deb12u1Fixed in 1:128.4.0esr-1Fixed in 1:128.4.2esr-1
  4. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 128.4
  5. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 132
  6. Upgrade

    Upgrade Firefox to a version that resolves this vulnerability.

    Fixed in 132
  7. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 128.4

Event History

Oct 29, 2024
CVE Published
via Mozilla·12:00 AM
CVE Published
via MITRE·12:19 PM
Data Sourced
via MITRE·12:19 PM
DescriptionWeakness
Data Sourced
via Red Hat·01:01 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·01:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·01:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2024-10464?

CVE-2024-10464 is classified as a moderate severity vulnerability due to the potential for causing Denial of Service in browser applications.

2

How do I fix CVE-2024-10464?

To fix CVE-2024-10464, upgrade to Mozilla Thunderbird version 132.0.1 or later, or Firefox version 132.0 or later.

3

What versions are affected by CVE-2024-10464?

CVE-2024-10464 affects Mozilla Thunderbird versions before 132 and Firefox versions before 132.

4

What kind of vulnerability is CVE-2024-10464?

CVE-2024-10464 is a Denial of Service vulnerability caused by repeated writes to history interface attributes.

5

Is CVE-2024-10464 related to any specific browsers?

Yes, CVE-2024-10464 specifically affects Mozilla Thunderbird and Firefox.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203