CVE-2024-46951: High severity Artifex Ghostscript vulnerability

Published Nov 10, 2024
·
Updated

An issue was discovered in psi/zcolor.c in Artifex Ghostscript before 10.04.0. An unchecked Implementation pointer in Pattern color space could lead to arbitrary code execution.

Affected Software

18 affected componentsFixes available
Artifex Ghostscript<10.04.0
Debian Debian Linux=12.0
SUSE Linux Enterprise High Performance Computing=12.0-sp5
SUSE Linux Enterprise Server=12-sp5
SUSE Linux Enterprise Server=12-sp5
SUSE Linux Enterprise Server=12-sp5
SUSE Linux Enterprise Server For Sap=12-sp5
debian/ghostscript<10.0.0~dfsg-11+deb12u6
10.0.0~dfsg-11+deb12u6
debian/ghostscript<10.04.0~dfsg-1
10.04.0~dfsg-1
debian/ghostscript<10.04.0~dfsg-1
10.04.0~dfsg-1
debian/ghostscript
10.0.0~dfsg-11+deb12u810.05.1~dfsg-1+deb13u110.05.1~dfsg-1+deb13u310.08.0~dfsg-2
alpine/ghostscript<10.04.0-r0
10.04.0-r0
alpine/ghostscript<10.04.0-r0
10.04.0-r0
alpine/ghostscript<10.04.0-r0
10.04.0-r0
alpine/ghostscript<10.04.0-r0
10.04.0-r0
alpine/ghostscript<10.04.0-r0
10.04.0-r0
alpine/ghostscript<10.04.0-r0
10.04.0-r0
alpine/ghostscript<10.04.0-r0
10.04.0-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/ghostscript to a version that resolves this vulnerability.

    Fixed in 10.0.0~dfsg-11+deb12u6
  2. Upgrade

    Upgrade debian/ghostscript to a version that resolves this vulnerability.

    Fixed in 10.04.0~dfsg-1
  3. Upgrade

    Upgrade debian/ghostscript to a version that resolves this vulnerability.

    Fixed in 10.0.0~dfsg-11+deb12u8Fixed in 10.05.1~dfsg-1+deb13u1Fixed in 10.05.1~dfsg-1+deb13u3Fixed in 10.08.0~dfsg-2
  4. Upgrade

    Upgrade alpine/ghostscript to a version that resolves this vulnerability.

    Fixed in 10.04.0-r0
  5. Upgrade

    Upgrade Artifex Ghostscript to a version that resolves this vulnerability.

    Fixed in 10.04.0

Event History

Nov 10, 2024
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·09:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·09:15 PM
DescriptionSeverityAffected Software
Data Sourced
via Red Hat·10:01 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-46951?

CVE-2024-46951 has a high severity level due to its potential for arbitrary code execution.

2

How do I fix CVE-2024-46951?

To fix CVE-2024-46951, update Ghostscript to version 10.04.0 or later.

3

Which versions of Ghostscript are affected by CVE-2024-46951?

CVE-2024-46951 affects Ghostscript versions prior to 10.04.0.

4

Can CVE-2024-46951 be exploited remotely?

Yes, CVE-2024-46951 can be exploited remotely if the vulnerable Ghostscript software is accessible.

5

What impact does CVE-2024-46951 have on systems using Ghostscript?

CVE-2024-46951 can lead to arbitrary code execution, allowing an attacker to take control of affected systems.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203